From 45622c7720bb950207d195af2bd2a6248ac96b85 Mon Sep 17 00:00:00 2001 From: Chris Tauchen Date: Fri, 23 Oct 2026 11:16:53 +0100 Subject: [PATCH 1/2] Bump Node to 22.23.4 Node 22.23.4 updates the bundled root certificate list in response to RHSB-2026-012. Netlify builds read the version from .nvmrc. --- .nvmrc | 2 +- README.md | 4 ++-- package.json | 2 +- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/.nvmrc b/.nvmrc index 6edc5a20f3..a9276c4bbc 100644 --- a/.nvmrc +++ b/.nvmrc @@ -1 +1 @@ -v22.17.0 +v22.23.4 diff --git a/README.md b/README.md index 0056ef06b0..992ee324d3 100644 --- a/README.md +++ b/README.md @@ -43,7 +43,7 @@ Built with [Docusaurus 3](https://docusaurus.io/), React 19, and TypeScript. Dep | | Native | Docker | |---------------|-------------------------------------------------|-------------------| -| **Requires** | Node.js v22.17.0+ (see `.nvmrc`), Corepack | Docker | +| **Requires** | Node.js v22.23.4+ (see `.nvmrc`), Corepack | Docker | | **Setup** | `nvm use && corepack enable` | Just have Docker running | This project uses Yarn 4.9.2, managed via [Corepack](https://nodejs.org/api/corepack.html). You must run `corepack enable` before any yarn commands. @@ -260,7 +260,7 @@ make calico-enterprise_versioned_docs/version-3.22-2__operator_reference | Problem | Solution | |---|---| -| Build fails with "Cannot find package '@docusaurus/logger'" | Wrong Node version. Need v22.17.0+ (check `.nvmrc`). | +| Build fails with "Cannot find package '@docusaurus/logger'" | Wrong Node version. Need v22.23.4+ (check `.nvmrc`). | | `packageManager` yarn error | Run `corepack enable` first. | | `make clean` fails when dependencies aren't installed | Use `make manual-clean` instead. | | React version mismatch warnings during `yarn install` | Expected and non-blocking. Safe to ignore. | diff --git a/package.json b/package.json index 857d9d3c16..e48a8c78c8 100644 --- a/package.json +++ b/package.json @@ -126,7 +126,7 @@ ] }, "engines": { - "node": ">=22.17.0" + "node": ">=22.23.4" }, "packageManager": "yarn@4.9.2" } From 2707cb2d71ed086fe7a37e21386d5b37c013b2ff Mon Sep 17 00:00:00 2001 From: Chris Tauchen Date: Fri, 23 Oct 2026 11:20:45 +0100 Subject: [PATCH 2/2] Update remaining Node 22.17.0 pins Semaphore indexing jobs and the Copilot instructions still named the old version. --- .github/copilot-instructions.md | 8 ++++---- .semaphore/semaphore.yml | 4 ++-- 2 files changed, 6 insertions(+), 6 deletions(-) diff --git a/.github/copilot-instructions.md b/.github/copilot-instructions.md index 2163d2f5e7..91a8582ad7 100644 --- a/.github/copilot-instructions.md +++ b/.github/copilot-instructions.md @@ -91,9 +91,9 @@ Examples: ## Critical Setup Requirements ### Node.js Version (CRITICAL) -- **Required**: Node.js v22.17.0 or later +- **Required**: Node.js v22.23.4 or later - **Why Critical**: Build fails with earlier versions (tested with v20.x) -- **Setup**: Use nvm if available: `nvm install 22.17.0 && nvm use 22.17.0` +- **Setup**: Use nvm if available: `nvm install 22.23.4 && nvm use 22.23.4` ### Package Manager Setup (CRITICAL) 1. **Enable Corepack**: `corepack enable` (required for containerized builds, recommended for local development) @@ -311,8 +311,8 @@ yarn test:screenshots # Visual regression tests (optional) ### Node Version Issues - **Problem**: Build fails with "Cannot find package '@docusaurus/logger'" -- **Solution**: Ensure Node.js v22.17.0+, run `corepack enable` first -- **Validation**: `node --version` should show v22.17.0+ +- **Solution**: Ensure Node.js v22.23.4+, run `corepack enable` first +- **Validation**: `node --version` should show v22.23.4+ ### Yarn Issues - **Problem**: "packageManager": "yarn@4.9.2" error with global yarn diff --git a/.semaphore/semaphore.yml b/.semaphore/semaphore.yml index 67e4733efa..140115f079 100644 --- a/.semaphore/semaphore.yml +++ b/.semaphore/semaphore.yml @@ -20,7 +20,7 @@ blocks: prologue: commands: - checkout - - sem-version node 22.17.0 + - sem-version node 22.23.4 - node --version - corepack enable - yarn --version @@ -40,7 +40,7 @@ blocks: prologue: commands: - checkout - - sem-version node 22.17.0 + - sem-version node 22.23.4 - corepack enable - node --version - yarn --version