Repository navigation
ci: pin the test matrix to ubuntu-24.04 so Python 3.9 can be installed - #39
Merged
Merged
Conversation
ubuntu-latest now resolves to Ubuntu 26.04, which has no Python 3.9 build. setup-python fails on the 3.9 job and fail-fast cancels the other four, so every run on main and every PR has been red. pyproject.toml still declares requires-python >= 3.9, so dropping 3.9 from the matrix would stop testing a supported version. Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
cubehouse
marked this pull request as ready for review
October 30, 2026 20:28
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
ubuntu-latestnow resolves to Ubuntu 26.04, which has no Python 3.9 build.setup-pythonfails on the 3.9 job and fail-fast cancels the other four.pyproject.tomlstill declaresrequires-python = ">=3.9", so the fix pins the runner instead of dropping 3.9. Only the matrix job is pinned. The docs job and the other workflows use Python 3.12 and stay onubuntu-latest.Evidence
mainfor deps: update ruff requirement from <0.17,>=0.4 to >=0.4,<0.18 in the dev-dependencies group #38 (run 41119063749):test (3.9)fails inRun actions/setup-python@v7with "The version '3.9' with architecture 'x64' was not found for Ubuntu 26.04", andtest (3.10)totest (3.13)are cancelled.test (3.9)totest (3.13)anddocs. That includes the ruff, mypy and pytest steps on Python 3.9.Merge Danger
Door: two-way
Blast Radius: CI only. After this lands, Dependabot PRs #25 and #37 and the spec-drift PR #35 need a rebase (
@dependabot rebasefor the first two) before their checks can go green.🤖 Generated with Claude Code