Skip to content
This repository was archived by the owner on Aug 18, 2026. It is now read-only.
This repository was archived by the owner on Aug 18, 2026. It is now read-only.

Schema Commentary Invalidates Setup #99

Description

@larron

-- Some comment here in your schema.sql file will cause substreams-sink-sql setup $DSN ./substreams.yaml to fail with something like:

substreams-sink-sql setup $DSN ./substreams.yaml
2025-08-01T04:36:10.832+0800 INFO (pipeline) computed start block {"module_name": "map_program_data", "start_block": 0}
2025-08-01T04:36:10.832+0800 INFO (pipeline) computed start block {"module_name": "db_out", "start_block": 0}
2025-08-01T04:36:10.833+0800 INFO (sink-sql) created new DB loader {"batch_block_flush_interval": 0, "batch_row_flush_interval": 0, "live_block_flush_interval": 0, "on_module_hash_mismatch": "Error", "handle_reorgs": false, "dialect": "*db.ClickhouseDialect"}                                                                                                                                                               
setup: exec userSql: exec schemaName: code: 62, message: Empty query

Currently testing with ClickHouse as seen in the log. (Have not tested this with a PG DB).

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions