Skip to content

Update flow to 25.2.16 - #9766

Merged
ZheSun88 merged 2 commits into
25.2from
update-flow-25.2.16-1793354812
Oct 30, 2026
Merged

ZheSun88 merged 2 commits into
25.2from
update-flow-25.2.16-1793354812

Conversation

@vaadin-bot

Copy link
Copy Markdown
Contributor

No description provided.

@github-actions

github-actions Bot commented Oct 30, 2026 •

Copy link
Copy Markdown
Contributor

Dependencies Report

  • 🚫 Vulnerabilities:

    • Vulnerabilities in: pkg:maven/com.google.guava/guava@33.6.0-jre [CVE-2026-102554] (osv-bomber,osv-scan)
      ·
    • Vulnerabilities in: pkg:maven/io.opentelemetry/opentelemetry-common@1.67.0 [CVE-2026-54285] (owasp)
      · cpe:2.3:a:opentelemetry:opentelemetry::::::node.js::*
  • 🟠 Known Vulnerabilities:

    • Vulnerabilities in: pkg:maven/io.opentelemetry/opentelemetry-api@1.65.0 [CVE-2026-118259, CVE-2026-54285] (osv-bomber,osv-scan,owasp)
      👌 False positive: the advisory is for opentelemetry-js and the CPE that matched targets node.js (cpe:2.3:a:opentelemetry:opentelemetry::::::node.js::), not the Java artifact. It reaches the sbom transitively through selenium-remote-driver under vaadin-testbench, a test only dependency. Same case as the 1.64.0 entry below. CVE-2026-118259 (GHSA-ccrj-gw8r-854m, fixed in 1.67.0) is a ReDoS in W3CTraceContextPropagator.extract() parsing inbound tracestate headers. Not affected: the artifact reaches the sbom only through selenium-remote-driver under vaadin-testbench, a test only dependency acting as an http client, so untrusted inbound headers are never extracted. Upgrade once selenium ships 1.67.0+.
      ·
      · cpe:2.3:a:opentelemetry:opentelemetry:
      :::::node.js::
    • Vulnerabilities in: pkg:npm/highcharts@12.2.0 [CVE-2026-118246, CVE-2026-118251, CVE-2026-118244, CVE-2026-116796, CVE-2026-118250] (osv-bomber,oss-bomber,osv-scan)
      👌 Fixed in Vaadin Charts without bumping the bundled Highcharts (announced as CVE-2026-107588): fix: skip unsupported values in chart options web-components#12886, cherry-picked to 25.1, 25.2 and 25.3, ignores reserved segments in series.keys and point option names, credits links without a supported URL scheme and event attribute names in style options applied as SVG attributes, and parses text markup in an inert document when the default parser fails. Scanners keep flagging 12.2.0 by version only. The bump to Highcharts 12.6.2 (feat: upgrade Highcharts to 12.6.2 web-components#13289) replaces these patches with the upstream fixes and clears the alert.
      ·
    • Vulnerabilities in: pkg:npm/picomatch@4.0.7 [CVE-2026-112366] (oss-bomber)
      👌 Build-time only: picomatch is pulled in by vite, rolldown and vite-plugin-checker and is not shipped in production bundles. The ReDoS requires an attacker supplied extglob pattern such as +(*), while the globs come from the developer's own build configuration. No fixed version is published on npm yet (4.0.7 is latest); upgrade once available.
      ·
    • Vulnerabilities in: pkg:npm/%40apidevtools/json-schema-ref-parser@11.7.2 [CVE-2026-15195] (oss-bomber)
      👌 The cve carries a git only range with no version mapping. The affected releases are 15.3.0 to 15.3.5, fixed in 15.3.6, while 11.7.2 predates that line by 17 months. It arrives through swagger-parser 10.1.1, which pins it exactly.
      ·
    • Vulnerabilities in: pkg:npm/lerc@3.0.0 [CVE-2026-10758] (oss-bomber)
      👌 Not affected: lerc arrives through ol -> geotiff and is only used to decode LERC compressed GeoTIFF imagery. Vaadin Map does not expose a GeoTIFF source, so the decoder is never on the execution path; worst case impact would be a crashed browser tab. vulnerable_code_not_in_execute_path.
      ·
    • Vulnerabilities in: pkg:maven/me.friwi/jcef-api@jcef-ca49ada%2Bcef-135.0.20%2Bge7de5c3%2Bchromium-135.0.7049.85 [CVE-2024-21639, CVE-2024-21640, CVE-2024-9410] (owasp)
      👌 Wait for the update from the jcefmaven community. Meanwhile the swing-kit is supposed to be used with fixed websites and not to browse the internet, we have a check for that, so the only possible attacker would be the same person that created the swing application, aka our customer devs. so this vulnerability is not classified by us as critical issue
      · cpe:2.3:a:chromiumembedded:chromium_embedded_framework::::::::
      · cpe:2.3:a:ada:ada::::::::
    • Vulnerabilities in: pkg:maven/org.jetbrains.kotlin/kotlin-stdlib@2.4.0 [CVE-2026-53914] (owasp)
      👌 False positive: osv.dev reports kotlin-stdlib 2.4.0 as not affected. owasp flags it via imprecise CPE matching. kotlin-stdlib comes from flow-webpush, which already declares 2.4.0.
      · cpe:2.3:a:jetbrains:kotlin::::::::
    • Vulnerabilities in: pkg:maven/com.vaadin/vaadin-swing-kit-flow@3.0.1 [CVE-2021-33604] (owasp)
      👌 false report: this CVE is targeting Vaadin version prior 20, swing-kit-flow is using vaadin 24+ version, the related issue has been fixed.
      · cpe:2.3:a:vaadin:flow-server::::::::
      · cpe:2.3:a:vaadin:vaadin::::::::
  • 📔 No Core License Issues

  • 📔 No License Issues

  • 🟠 Changes in 25.2-SNAPSHOT since V25.2.12

    • 2 packages removed (2 external, 0 vaadin)
    • 1 packages added (1 external, 0 vaadin)
    • 142 packages modified (54 external, 88 vaadin)
    • 491 packages same (343 external, 148 vaadin)

[Click for more Details]

Automated maintenance-version updates against `25.2`, discovered by `scripts/check-versions`.

## Updates

- `vaadin/vaadin-testbench`: javaVersion `25.2.3` → `25.2.4`

_Generated by `scripts/check-versions/src/index.ts`._

Co-authored-by: github-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>
@ZheSun88
ZheSun88 enabled auto-merge (squash) October 30, 2026 10:18
@ZheSun88
ZheSun88 merged commit d36efea into 25.2 Oct 30, 2026
3 of 4 checks passed
@ZheSun88
ZheSun88 deleted the update-flow-25.2.16-1793354812 branch October 30, 2026 10:45
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants